找回密码
 加入我们
关闭

CSDN热搜

草根吧
首页 官方推荐社区 编程语言 距离向量路由协议——RIP

开发语言 间隔向量路由协议——RIP

IP:广东省广州市
昏昏欲睡 2023-12-3 09:59:51来自手机
静态路由

静态路由简介

为什么需要静态路由



  • 假如采用静态路由设备路由器R1,到达主机B的数据包将从路由器R2经过。当路由器R1和R2之间的毗连出现故障时,主机A和主机B将没法通讯,即使现实上还存在别的一条通路。治理员也可以立即重新设备路由器,改变路由表,使得数据包从路由器R3经过。但是假如这是一个范围庞大的收集(例如是Internet),经常会有链路在断开或规复,治理员底子没法完成如此庞大的工作。这时可以采用静态路由协议。
  • 静态路由协议可以也许静态地反应收集的状态,当收集发生变化时,收集合的路由器会把这个消息通告给其他的路由器,终极全数的路由器将晓得收集的变化,能实时调解路由表,从而保证数据包的一般传输。

静态路由底子道理



  • 静态路由协议的底子脑筋就是路由器之间要相互交换路由信息,一个静态路由协议都要有两个底子功用:保护本身的路由表、以路由更新的形式将路由信息实时公布给其他路由器。
  • 静态路由的底子道理是依靠静态路由协议使得路由器之间可以也许相互交换路由信息。路由器和路由器之间交换路由信息时要服从一组法则,这组法则就是静态路由协议。一个路由协议重要包含以下几项内容:

  • 怎样发送路由更新信息(怎样发送)?
  • 更新信息包括哪些内容(发送什么)?
  • 什么时候发送这此更新(何时发送)?
  • 怎样肯定更新信息的罗致者(发送给谁)?
路由协议的分类

路由协议的分类按照路由协议是在什么路由器之间交换路由信息,路由协议可以分为两大类:内部网关协议(Interior Gateway Protocol,IGP)和内部网关协议(Exterior Gateway Protocol,EGP)。



  • IGP内部网关协议运转在一个自治系统(Autonomous System,AS)中,该类路由协议用于同一 AS内部的路由器之间交换路由信息。所谓自治系统可被以为是一个公共治理部分下的一组收集装备,例如一个ISP或一个公司的广域网就是一个自治系统。例如RIP、IGRP、EIGRP、OSPF都是IGP。
  • EGP内部网关协议运转在各个自治系统之间,该类路由器协议用于不同AS的路由器之间交换路由信息。例如:因特网由不计其数的收集毗连而成:各个ISP都有自己的自治系统。但各个自治系统都经过EGP毗连在一路。
  • 按照路由协议的工作道理,IGP还可以进一步分为间隔向量路由(Distance Vector.DV)协议、链路状态路由(Link State,LS)协讲和混淆路由协议。间隔向量路由协议重要有:RIP(Routing Information Protocol,路由信息协议)、IGRP(Interior Gateway Routing Protocol,内部网关路由协议);链路状态路由协议重要有OSPF(Open Shortest Path First,开放的最长途径优先协议)、IS-IS(Intermediate System-toIntermediate System,间系统到中心系统协议)、混淆协议重要有EIGRP(Enhanced IGRP,增强型内部网关路由协议)。有的材料把EIGRP归类到间隔向量路由协议中。

间隔向量路由协议

RIPv1



  • RIPv1是有种别路由协议,不支持VLSM和CIDR;RIPv2为无种别路由协议,支持VLSM,支持路由聚合与CIDR。
  • RIPv1以广播的形式发送报文;RIPv2支持以广播大概组播(224.0.0.9)方式发送报文。
  • RIPv1不支持认证;RIPv2支持明文认证和MD5密文认证。
RIP简介



  • RIP(Routing Information Protocol,路由信息协议)最大的特点是不管实现道理照旧设备方式都很是简单。RIP中路由更新是经过广播(RIPv1)和组播(RIPv2)实现的。默许情况下,路由器每隔30秒利用UDP520端口向与它相连的收集广播自己的路由表,接到广播的路由器将收到的信息增加至本身的路由表中。每个路由器都如此转达路由信息,终极收集上全数的路由器城市得知全数的路由信息。
  • 任何间隔向量路由协议(如RIP),都有一个题目,即路由器不晓得收集的全局情况。路由器必须依靠相邻的路由器来获得收集的可达信息。由于路由更新在收集上传布慢,将会致使收集收敛较慢,形成路由环路。假如收集上有路由环路,信息就会循环转达,永久不能到达方针地。为了避免这个题目,RIP 等间隔向量算法经过下面5个机制来避免路由环路。

  • 水中朋分(Split Horizon)
    水中朋分保证路由器记着每一条路由信息的根源,而且不在收到这条信息的端口上再次发送它。这是保证不发生路由循环的最底子办法。
  • 毒性逆转(Poison Reverse)
    当一条途径信息变成无效以后,路由器并不立行将它从路由表中删除,而是将路由条方针怀抱值标志为16跳,即不成达的怀抱值将它广播进来。这样固然增加了路由表的巨细,但抵消除路由循环很有帮助,它可以立即断根相邻路由器之间的任何环路。
  • 界说最大跳数(DefiningaMaximum Count)
    RIP的怀抱是基于跳数的,每经过一台路由器,途径的跳数加一。如此一来,跳数越多,途径就越长,RIP算法会优先挑选跳数少的途径。RIP支持的最大跳数是15,跳数为16的收集被以为不成达。
  • 触发更新(Triggered Update)
    当路由表发生变化时,更新报文立即广播给相邻的全数路由器,而不是等待30秒的更新周期。一样,当一个路由器刚启动RIP时,它广播请求报文,收到此广播的相邻路由器立即应对一个更新报文,而不必等到下一个更新周期。这样,收集拓扑的变化会最快地在收集上传布开,淘汰了路由循环发生的大要性。RIPv1和RIPv2都支持触发更新。
  • 禁止计时(Holddown Timer)
    一条路由信息无效以后,一段时候内这条路由都处于禁止状态,即在肯按时候内不再罗致关于同一方针地点的路由更新,除非有更好的途径。由于路由器从一个网段上得知条途径生效,然后立即在另一个网段上得知这个路由有用。这个有用的信息常常是不切确的,禁止计时避免了这个题目,而且,当一条链路频仍起停时,禁止计时淘汰了路由的翻转(Flapping),增加了收集的稳定性。
   收敛:对于路由协议,收集上的路由器在一条途径不能利用时必须履历决议替换途径的进程,是在最好途径的判定上全数路由器到达分歧的进程。当某个收集事变引发路由可用或不成用时,路由器就发出更新信息。路由更新信息遍及全部收集,激发重新计较最好途径,终极到达全数路由器分歧公认的最好途径。这个进程即称为收敛。
收敛时候指从收集发生变化起头直到全数路由器识别到变化并针对该变化作出顺应为止的这段时候。 收敛慢的路由算法会形成途径循环或收集停止。收敛进程既具合作性,又具自力性。路由器之间既需要同享路由信息,各个路由器也必须自力计较拓扑结构变化对各自路由进程所发生的影响。由于路由器自力更新收集信息以与拓扑结构连结分歧,所以,也可以说路由器经过收敛来告竣分歧。收敛的有关属性包含路由信息的传布速度以及最好途径的计较方式。可以按照收敛速度来评价路由协议。
收敛速度越快,路由协议的性能就越好。凡是,RIP和IGRP收敛较慢,而EIGRP、OSPF和IS-IS收敛较快
  RIP利用于OSI收集七层模子的利用层。

RIPv1的重要特征

RIP最初界说在RFC1058中,它的关键特点包含以下内容:

  • 它是间隔向量路由协议;
  • 它利用跳数作为怀抱值,而且最大跳数为15,跨越15跳,则以为路由不成达,抛弃数据包;
  • 采用广播方式(255.255.255.255)停止路由更新;
  • 路由更新周期为30秒;
  • RIP路由协议的治理间隔为120
  • 它是有种此外(Classful)路由协议
RIPv1的底子设备

在路由器上设备RIPv1协议分为两个步调:
(1)启动RIP进程,默以为版本1。
命令语法:Router(config)#router rip
(2)界说要宣布的直连主类收集号。
命令语法:Router(config)#network <network>
   第二个network表示收集地点
收集地点是IP地点中收集位稳定,主机位置为0的地点(在子网掩码中,收集位全为1,主机位全为0)
  由于RIPv1是有种此外协议,所以利用network命令时,只公布A类、B类或C类收集即可。


  • distribute-list命令(设备路由过滤)
  • 该命令用于指定有路由过滤功用的接口,在被指定的路由器的接口上,既可以过滤其罗致的路由更新信息,还可以过滤输出的路由更新信息,它常与“passive-interface”一路利用,这样被指定的接口既可以过滤罗致的路由信息,也可阻止该路由器更新信息的输出,即禁止该接口加入RIP。
    它的命令格式为“distribute-list <接口>”
   例如:router-test(config)#router rip (启动RIP协议)
router-test(config-router)# distribute-list 10 in FastEthemet0/1 (其中 10为已在全局设备形式下设备的拜候控制列表,其中界说了路由过滤信息)
router-test(config)#end (end间接退回到特权用户形式)
router-test #
  

  • distance命令 (设备治理间隔)。
    该命令用来设备或改变RIP的治理间隔,治理间隔用来丈量路由的可信度,该值越小则可信度越高,RIP的默许间隔值是120,有用的治理间隔值是1 ~255。
    它的命令格式为“distanc<治理间隔 >”
    如在全局设备形式下:
   router-test(config) #router rip
router-test(config-router)#distance 100(设备治理间隔为100)
router-test(config-router)#exit
router-test(config)#exit
router-test #
  RIPv1设备案例


利用RIPv1版本停止设备

路由器R1的设备:
   Router>enable
Router#configure terminal
Router(config)#hostname R1
R1(config)#interface FastEthernet0/0
R1(config-if)#ip address 10.1.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#interface Serial0/3/0
R1(config-if)#ip address 12.12.12.1 255.255.255.0
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#router rip
R1(config-router)#network 10.0.0.0
R1(config-router)#network 12.0.0.0
R1(config-router)#
  路由器R2的设备:
   Router>enable
Router#configure terminal
Router(config)#hostname R2
R2(config)#interface Serial0/3/0
R2(config-if)#ip address 12.12.12.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#interface Serial0/3/1
R2(config-if)#ip address 23.23.23.2 255.255.255.0
R2(config-if)#exit
R2(config)#interface Serial0/3/1
R2(config-if)#clock rate 64000
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#router rip
R2(config-router)#network 12.0.0.0
R2(config-router)#network 23.0.0.0
R2(config-router)#
  路由器R3的设备:
   Router>enable
Router#configure terminal
Router(config)#hostname R3
R3(config)#interface Serial0/3/0
R3(config-if)#ip address 23.23.23.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#interface FastEthernet0/0
R3(config-if)#ip address 192.168.1.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#router rip
R3(config-router)#network 23.0.0.0
R3(config-router)#network 192.168.1.0
R3(config-router)#
  

  • 利用“show ip route”命令来检察路由表

  • 利用“debug ip rip”可以检察RIP路由协议的静态更新进程。为了立即看到成果,可以利用“clear ip route *”断根路由表。

被动接口



  • passive-interface命令(设备被动接口)。
    所谓被动接口指,在路由器的某个接口上只罗致路由更新却不发送路由更新。
    它的命令格式为“passive-interface <接口>”
   例如:router-test(config)#router rip
router-test(config-router)# passive-interface Serial0/3/0
router-test(config-router)#exit
router-test(config)#exit
router-test #
  将R2左侧的Serial0/3/0设备成被动接口:

单播更新



  • neighbor命令(设备邻人路由器)。
    该命令用于指定邻人路由器,这样,在RIP路由器不允许发送广播包或是在收集技术不支持收集广播的特别情况下,路由器仍可以单播的方式向该邻人路由器发送路由更新信息。
    它的命令格式为“neighbor <邻人路由器的IP地点>”
   router-test(config) #router rip
router-test(config-router)#neighbor 131.55.101.2
router-test(config-router)#exit
  路由器Router1只想把路由更新发送到路由器Router3上,由于RIPv1路由协议采用广播更新,默许情况下,路由更新将发送赐与太网上任何一个装备,为了避免这类情况发送,把路由器Router1的f0/0设备成被动接口,但是Router1还想把路由更新发送给Router3,这时候必须采用单播更新,为指定的相邻路由器Router3发送路由更新。
   Router1(config)#router rip
Router1(config)#network 10.0.0.0
Router1(config)#passive-interface f0/0
     Router1(config)#neibor 10.1.1.3

    利用子网地点

由于RIPv1的有种别特征,决议了它在路由器更新中不照顾子网信息。
例如,当路由器R1向路由器R2发送路由更新10.1.1.0时,它将被自动汇总为10.0.0.0;当路由器R2收到这个更新时,它将抛弃更新,由于它的一个接口毗连在收集10.0.0.0上,路由器R2将不罗致这条路由。
该题目标打点计划就是全部收集全数地点必须在同一个主类收集,而且需要利用类似长度的子网掩码。这样,在RIPv1的路由更新中也可以转达子网信息了。


路由器R1的设备:
   Router(config-if)#interface FastEthernet0/0
Router(config-if)#ip address 10.1.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#interface Serial0/3/0
Router(config-if)#ip address 10.1.3.1 255.255.255.0
Router(config-if)#clock rate 64000
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#router rip
Router(config-router)#network 10.0.0.0
Router(config-router)#
  路由器R2的设备:
   Router(config-if)#interface Serial0/3/0
Router(config-if)#ip address 10.1.3.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#interface FastEthernet0/0
Router(config-if)#ip address 10.1.2.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#router rip
Router(config-router)#network 10.0.0.0
  从路由器R1和R2的输出可以看出,假如全部收集全数地点都在同一个主类收集,而且收集掩码长度类似,RIPv1确切可以转达子网信息。
RIPv2

RIPv2的底子设备

在路由器上设备RIPv2协议分为四个步调:
(1)启动RIP进程。
命令语法:Router(config)#router rip
(2)声明版本号。
Router(config-router)#version 2
(3)宣布直连主类收集号
Router(config-router)#network <network-number>
(4)封闭自动汇总
Router(config)#no auto-summary
RIPv2设备案例


利用RIPv2版本停止设备

路由器R1的设备:
   Router>enable
Router#configure terminal
Router(config)#hostname R1
R1(config)#interface FastEthernet0/0
R1(config-if)#ip address 10.1.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#interface Serial0/3/0
R1(config-if)#ip address 12.12.12.1 255.255.255.0
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 10.1.1.0
R1(config-router)#network 12.12.12.0
R1(config-router)#no auto-summary
  路由器R2的设备:
   Router>enable
Router#configure terminal
Router(config)#hostname R2
R2(config)#interface Serial0/3/0
R2(config-if)#ip address 12.12.12.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#interface Serial0/3/1
R2(config-if)#ip address 23.23.23.2 255.255.255.0
R2(config-if)#clock rate 64000
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 12.12.12.0
R2(config-router)#network 23.23.23.0
R2(config-router)#no auto-summary
  路由器R3的设备:
   Router>enable
Router#configure terminal
Router(config)#hostname R3
R3(config)#interface Serial0/3/0
R3(config-if)#ip address 23.23.23.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#interface FastEthernet0/0
R3(config-if)#ip address 192.168.1.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#network 23.23.23.0
R3(config-router)#network 192.168.1.0
R3(config-router)#no auto-summary
  RIPv2支持可变宗子网掩码(VLSM),所以收集地点依照一般的输入即可。
测试连通性:主机A和主机B可一般通讯



  • RIPv1和RIPv2的路由表对照

  • 利用“show ip protocols”命令表示路由器上启用的IP路由协议,并对每种协议有用的信息给出一个汇总。

  • 利用“debug ip rip”可以检察RIP路由协议的静态更新进程。

RIPv2的高级设备

输入“ip rip”开首的命令都表示有题目,不晓得什么缘由,待打点。
与RIPv1的兼容性



路由器R1的设备:
   Router>enable
Router#configure terminal
Router(config)#hostname R1
R1(config)#interface FastEthernet0/0
R1(config-if)#ip address 10.1.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#interface Serial0/3/0
R1(config-if)#ip address 12.12.12.1 255.255.255.0
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 10.1.1.0
R1(config-router)#network 12.12.12.0
R1(config-router)#no auto-summary
R1(config-if)#exit
R1(config)#interface Serial0/3/0
R1(config-if)ip rip receive version 1 2
  路由器R2的设备:
   Router>enable
Router#configure terminal
Router(config)#hostname R2
R2(config)#interface Serial0/3/0
R2(config-if)#ip address 12.12.12.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#interface Serial0/3/1
R2(config-if)#ip address 192.168.1.0 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#router rip
R2(config-router)#network 12.0.0.0
R2(config-router)#network 192.168.1.0
R2(config-router)#
  手工路由汇总

RIPv2的手工汇总的设备和EIGRP设备底子类似。仍然会出现无效命令的提醒。

触发更新

RIP路由协议支持触发更新,这也是避免环路的一种方式。实现方式很简单,只需在接口下输入下面命令即可:R1(config-if) # ip rip triggered
留意:ip rip triggered 命令不能在以太口上利用


MD5认证

RIPv2支持明文和密文认证。密文认证是一种比力平安的认证方式,所以,这里仅会商密文认证。RIPv2密文认证采用MD5认证,认证的设备和EIGRP的认证底子类似。


路由器R1的设备:
   Router>enable
Router#configure terminal
Router(config)#hostname R1
R1(config)#key chain keychain1 (keychain1为钥匙串称号)
R1(config-keychain)#key 1 (设备钥匙1,可以设备多个钥匙)
R1(config-keychain-key)#key-string cisco

R1(config)#interface FastEthernet0/0
R1(config-if)#ip address 10.1.1.1 255.255.255.0
R1(config-if)#ip rip authentication mode md5 (翻开rip认证,认证形式是明文,还有MD5方式)
R1(config-if)#ip rip authentication key-chain lgm (设备钥匙串称号)

R1(config-if)#no shutdown
R1(config-if)#interface Serial0/3/0
R1(config-if)#ip address 12.12.12.1 255.255.255.0
R1(config-if)#clock rate 64000
R1(config-if)#ip rip authentication mode md5
R1(config-if)#ip rip authentication key-chain lgm

R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 10.1.1.0
R1(config-router)#network 12.12.12.0
R1(config-router)#no auto-summary
  路由器R2的设备:
   Router>enable
Router#configure terminal
Router(config)#hostname R2
R2(config)#key chain keychain2 (钥匙串称号可以和R1不同)
R2(config-keychain)#key 1 (钥匙ID和钥匙密码必须和R1分歧)
R2(config-keychain-key)#key-string cisco

R2(config)#interface Serial0/3/0
R2(config-if)#ip address 12.12.12.2 255.255.255.0
R2(config-if)#ip rip authentication mode md5 (形式要设备一样)
R2(config-if)#ip rip authentication key-chain lgm

R2(config-if)#no shutdown
R2(config-if)#interface Serial0/3/1
R2(config-if)#ip address 23.23.23.2 255.255.255.0
R2(config-if)#clock rate 64000
R2(config-if)#ip rip authentication mode md5
R2(config-if)#ip rip authentication key-chain lgm
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 12.12.12.0
R2(config-router)#network 23.23.23.0
R2(config-router)#no auto-summary
  路由器R3的设备:
   Router>enable
Router#configure terminal
Router(config)#hostname R3
R3(config)#key chain keychain3 (钥匙串称号可以和R1不同)
R3(config-keychain)#key 1 (钥匙ID和钥匙密码必须和R1分歧)
R3(config-keychain-key)#key-string cisco

R3(config)#interface Serial0/3/0
R3(config-if)#ip address 23.23.23.3 255.255.255.0
R3(config-if)#ip rip authentication mode md5 (形式要设备一样)
R3(config-if)#ip rip authentication key-chain lgm

R3(config-if)#no shutdown
R3(config-if)#interface FastEthernet0/0
R3(config-if)#ip address 192.168.1.3 255.255.255.0
R3(config-if)#ip rip authentication mode md5
R3(config-if)#ip rip authentication key-chain lgm
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#network 23.23.23.0
R3(config-router)#network 192.168.1.0
R3(config-router)#no auto-summary

免责声明:本文章来自网友分享,假如加害了您的权益,请联系我们,我们会实时删除侵权内容,感谢合作!

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有账号?加入我们

x

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们