• 售前

  • 售后

热门帖子
入门百科

办理Ubuntu下利用linuxdeployqt打包Qt步调问题

[复制链接]
shelly65321 显示全部楼层 发表于 2021-10-26 14:06:03 |阅读模式 打印 上一主题 下一主题
写了点Qt界面步调,然而发现很难移植到其他没有安装Qt环境的电脑上运行。查资料相识到,在windows上有windowsdeployqt步调,linux上有linuxdeployqt可以帮助我们快速打包。
1. 设置Qt环境
首先,我们先把Qt环境设置好,在~/.bashrc中加入:
  1. export PATH=/home/xl/Qt5.9.2/5.9.2/gcc_64/bin:$PATH
  2. export LD_LIBRARY_PATH=/home/xl/Qt5.9.2/5.9.2/gcc_64/lib:$LD_LIBRARY_PATH
  3. export QT_PLUGIN_PATH=/home/xl/Qt5.9.2/5.9.2/gcc_64/plugins:$QT_PLUGIN_PATH
  4. export QML2_IMPORT_PATH=/home/xl/Qt5.9.2/5.9.2/gcc_64/qml:$QML2_IMPORT_PATH
复制代码
此中/
  1. home/xl/Qt5.9.2/5.9.2/
复制代码
目次要根据本身电脑上安装的Qt路径进行修改。
然后执行
  1. sourec ~/.bashrc
复制代码
使设置收效。
2. 编译linuxdeployqt
项目地点: https://github.com/probonopd/linuxdeployqt.git 。
固然有放出编译好的包,但是由于我使用的是Ubuntu18, 系统版本过高,因此还是选择编译代码的方式。
为了制止编译好的包运行时检测到我们的系统版本过高,不继承执行的题目,我们编译前,将
  1. tools/linuxdeployqt/main.cpp
复制代码
中的下述代码注释掉:
  1. // openSUSE Leap 15.0 uses glibc 2.26 and is used on OBS
  2.     /*if (strverscmp (glcv, "2.27") >= 0) {  //注释版本检查
  3.       qInfo() << "ERROR: The host system is too new.";
  4.       qInfo() << "Please run on a system with a glibc version no newer than what comes with the oldest";
  5.       qInfo() << "currently still-supported mainstream distribution (xenial), which is glibc 2.23.";
  6.       qInfo() << "This is so that the resulting bundle will work on most still-supported Linux distributions.";
  7.       qInfo() << "For more information, please see";
  8.       qInfo() << "https://github.com/probonopd/linuxdeployqt/issues/340";
  9.       return 1;
  10.     }*/
复制代码
然后就可以使用cmake和make进行编译。天生好的可执行步调是
  1. tools/linuxdeployqt/linuxdeployqt
复制代码

末了为了方便使用,可以将天生的可执行步调拷贝到系统的
  1. /usr/local/bin/
复制代码
目次。
3. 打包
将Qt编译的好的步调拷贝到一个单独的文件夹中。
然后执行
  1. linuxdeployqt appname.
复制代码
一般环境下会很顺遂的完成,当前目次下会有个Apprun,直接执行它就可以。
但是有时间并不是那么顺遂,应该是系统中还缺少相应的库。好比,我碰到的错误是:
  1. ERROR: Could not start patchelf.
  2. ERROR: Make sure it is installed on your $PATH.
  3. ERROR: Error reading rpath with patchelf "libQt5Widgets.so" : ""
  4. ERROR: Error reading rpath with patchelf "libQt5Widgets.so" : ""
复制代码
这个错误是表明缺少必要的pathchelf工具,直接安装即可解决:
  1. sudo apt install patchelf
复制代码
然后又出现了下面这个错误:
  1. ERROR: ldd outputLine: "libjasper.so.1 => not found"
  2. ERROR: for binary: "/home/xl/Qt5.9.2/5.9.2/gcc_64/plugins/imageformats/libqjp2.so"
  3. ERROR: Please ensure that all libraries can be found by ldd. Aborting.
复制代码
这表明我们系统中是缺少了libqjp2.so这个库的。实在很奇怪,本地明明是已经可以跑起来了,为什么还缺少这个库文件。但是解决方法很简朴,缺什么就装什么:
  1. sudo add-apt-repository "deb http://security.ubuntu.com/ubuntu xenial-security main"
  2. sudo apt update
  3. sudo apt install libjasper1 libjasper-dev
复制代码
安装完成之后,就顺遂打包了。

总结
以上所述是小编给各人先容的解决Ubuntu下使用linuxdeployqt打包Qt步调题目,希望对各人有所帮助,如果各人有任何疑问请给我留言,小编会及时回复各人的。在此也非常感谢各人对脚本之家网站的支持!
如果你觉得本文对你有帮助,接待转载,烦请注明出处,谢谢!

帖子地址: 

回复

使用道具 举报

分享
推广
火星云矿 | 预约S19Pro,享500抵1000!
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

草根技术分享(草根吧)是全球知名中文IT技术交流平台,创建于2021年,包含原创博客、精品问答、职业培训、技术社区、资源下载等产品服务,提供原创、优质、完整内容的专业IT技术开发社区。
  • 官方手机版

  • 微信公众号

  • 商务合作